GUI editor to tame mod_security rules

⌈⌋ branch:  modseccfg


Artifact [1f6629aa07]

Artifact 1f6629aa078e24e5821e93bb6d729e210520a3374be4f0a2688d80fdf99079f3:

  • Executable file setup.py — part of check-in [cf99bb8fa7] at 2022-10-21 22:49:19 on branch trunk — add msc_pyparser option dependency `pip install modseccfg[all]` (user: mario size: 809)

#!/usr/bin/env python3
# encoding: utf-8
# api: pip
# type: build
# title: config for setuptools
#
# Always prefer setuptools over distutils
#

from pluginconf.setup import setup

setup(
    #debug=1,
    fn="modseccfg/__init__.py",
    name="modseccfg",
    long_description="README.rst",
    packages=["modseccfg"],
    package_dir={"": "."},
    package_data={
        "modseccfg": [
            "./data/*.*",
            "./install/*.*",
            "./scripts/*"
        ],
    },
    include_package_data=True,
    # data_files=[("man/man1", ["manpage/modseccfg.1"])),  # automatically done in pluginconf.setup now
    entry_points={
        "console_scripts": [
            "modseccfg=modseccfg.mainwindow:main",
        ]
    },
    extras_require = {
        "all": ["msc_pyparser >= 1.1.1"]
    }
)